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Hypermedia 1997 
Interactive Movie exercise 
 
 
 
In this exercise you will create a small movie with animation and buttons 
which lead to two other sections in response to a user action- a mouseUp 
click. A third button will take you back to the beginning of the movie. This is 
an example of a basic interactive "tree" structure 
 
You will need to provide 5 graphics and should eventually have a mixture of 
scanned, manipulated and drawn material (anything simple will do). To 
begin with, jusr use the Paint window in Director to create your graphics. 
 

•One graphic to act as a background, (to be full screen it will need to be 
640 x 480 pixels, at 72 dpi.) 
 
•At least one graphic to animate on top of the background 
 
•Three smaller graphics (on a white background) to act as buttons.  
 
•Later, you will add sound to this exercise, one piece of atmos running 
through the project, and 2 or 3 sound effects or 'puppet' sounds that play 
in response to a mouse click.  

 
Follow the exercise step by step and don't miss any points! 
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clicking on "button a" 
takes you to "option a" 
clicking on "button b" 
takes you to "option b" 
clicking on "button c" 
takes returns you back to 
"begin movie" 
 
 
 
 
Part 1- 
Importing the 
graphics into the 
Director "cast" 
 
 
First create tyour image 
Cast Members within 
Director using the Paint 
window. 
First we will import our 
images into Director's cast 
window.  
 
1 Open up Director. 

The Window menu 
is where you'll find 
Cast, Score, Paint 
and Control Panels 
when you need 
them. 

 
2 Open up the Cast 

Window and the 
Paint Window. 
Working in the 
Paint Window, 
select a paint tool 
and colours to begin 
creating your first 
cast member- a 
background. When 
you have finished it, 

click on the Cast Window to bring it to the front and you will see it appears 
automatically in your cast window. Click on or open the Paint Window again (or just 
double click on the Cast Window )and use the + icon to bring up an new cast member 
that you will now "paint". Repeat for all of your images/cast members. 

 
Note:-You could also import scanned image files into Director's cast window by doing  the 
following:-  this will also be covered in workshops 
 (Open the Cast window, from the File menu select Import to bring in the graphics to 

frame 1
begin movie

button b 

button c

An animation 
will occur

frame 4s0
end animation 
movie hovers until
user clicks

option a option b

button a

this button will take you back to frame 1
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use as your background and buttons. Select each file, click Add for more than one file, 
then click Import button to bring them into an Internal Cast.) 

 
3 Open the Score window. First we will place our background. Select it in the Cast (or 

Internal cast) window, and drag it into the first frame in Channel 1 of the score. You 
will notice that it will automatically appear across several frames in Channel 1 of the 
Score, and will be perfectly centred on the Stage).  

 
4 Select the second cast member from the Cast window and drag it directly to the stage. 

To position it where you like, make sure that all of the cells in Channel 2 are selected 
by clicking on the horizontal line in the middle, which will "darken" the frames. You 
will see when looking back at the Stage that your selected Cast member has a 
bounding box around it. You can now move it to wherever you like on the screen. 

 
5 You will probably need to get rid of the white background on the second image. In 

the Score, select the cells by clicking on the horizontal line in the correct channel and 
then select Ink>Background Transparent. 

 
6 Save your movie (from the File menu). 
 
 
 
 
 
 
 
 
 
 
 
 
Part 2- Animation 
Now we will create some basic animation for the next 40 frames 
 
7 Close down all of your windows apart from the Control Panel, and make sure that 

the loop icon is selected. Press play and you will see a static image, but you will 
notice the counter turning over in the control panel. 

 
8 Open up the Score Window. Extend the length of time the images are on the stage  

out to 40 frames by clicking and dragging the rectangle at the end of the each channel 
which has cast members (sprites) on it. 

 
9 Place your next two cast members (buttons a & b) in Channels 3 & 4 at frame 40 for 

one frame only ( by contracting the rectangle at the end of the sprites). Make sure they 
are not sitting on top of one another. Eventually these will  hover at frame 40 and act 
as buttons to take us to other parts of the movie. Play your movie and you will see 
these buttons flashing on at frame 40.  

 Now we will animate the graphic in Channel 2 
 
 
Basic Animation in Director 6 
 
9a.  i. Select the sprites in Channel 2 of the score, making sure all are selected by clicking 

on the horizontal line. Make sure the red playback head is at frame 1. 
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 ii. Now position the sprite in the location that you want your animation to start. 
 
 iii. In the scoreplayback region, click at frame 10. You should now have a red line at 

frame 10. Select Insert>Keyframe. Look at the Score again and you will see that a 
circle appears at Frame 10 of Channel 2- a keyframe has been created there. 

 
 iv. Now position the sprite in a different position on the Stage. Rewind and play the 

movie. Director has automatically inbetweened the frames from the first keyframe to 
the second keyframe. 

 
 v. Create another keyframe at frame 20 by  
   •selecting channel 2 in the score 
   •clicking on frame 20 in playback region 
 
 Now position the sprite at frame 20 in a different position on the stage. Play back. 

Now repeat the process to get a movement that you are happy with. 
 
 
 Some further methods of animation are being handed out for you to try. See how far 

you get.  
 
 
 
 
 
 
 

Making the movie interactive 
 
Here we need to make the movie "hover" at frame 30 and wait for a mouse click for the movie to 
continue: 
 
10 Double-click in the script channel for frame 30, a script window opens. 
 On the next line after on ExitFrame, type: 
 
 go to the frame 
 
 then click on the close box. 
 
11 Turn off the looping button and play your movie again. Notice how the playback 

head sits on frame 30, but the playback button is still engaged, so the movie is still 
playing, but hovering at frame 30.  

 
12 Stop your movie and save. (It is good practise to stop the movie before modifying 

scripting, altering scripts while the movie is still running can cause confusion so press 
the stop button on the control panel beforehand.) 

 
Creating markers 
Now we need to label some markers at particular frames so clicking on a button can take us to that 
frame   
 
13 Make a marker at frame 30 by dragging the triangle out of the marker well, over to 

frame 30. Type in makechoice. So now when you play the movie it hovers at the 
frame  "makechoice".  
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 You should have button a and button b visible at the "makechoice" hover point so that 
they can  make a choice. 

 
 
• You can identify frames by numbers, eg in a script window a script could say, "go to frame 

10", but it is much safer to create markers and identify frames by naming them, as you may be 
copying and pasting cells and the score numbering may change. It is also good practise to 
leave a few blank spaces between sections (and hover points) in a movie to allow for the need to 
extra cells to be pasted in, and to make it easier to see.   

 

 
 
14 Now create some more markers so that when the user selects button a or button b, 

they are taken to the appropriate part of the movie. Make a marker at frame 40, call it 
option a,  one at frame 60  called option b and one at frame 1 called  

 begin movie. When creating markers, be careful  to note where spaces occur in between 
words, as when Lingo scripts refer to marker names, the wording must be precise. 

 
 

 
 
15.   Open up the paint window and create a new cast member (by clicking the + sign as 

per the window above). Use the text tool and type "you are now at option a". Double-
clicking on the text tool will allow you to change fonts, size etc. Close the paint window 
and then drag this cast member into frame 40 and inbetween it up until frame 42. 
Create a marker at frame 42 and name it ahover. Then open up the script channel at 
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frame 42 and type 
  go to the frame 
 
16. Repeat what you did at point 15 but this time for option b. ie open up paint window, 

"you are now at option b". Drag this new cast member into frame 60, and inbetween 
up until frame 62. Create a marker at frame 62 called bhover. Open up script channel 
at frame 62 and type 

  go to the frame 
 
 Save your movie 
 
 
We need to add scripts to our cast members to get them to behave as buttons and respond to a 
mouse click to move to another part of the movie.  
 
17 Open the cast window.  
 

 
 
18 In the Internal Cast window, select your cast member that acts as button a in our 

example. Click on the script icon in this window. In the script window, you will see: 
 on mouseUp 
   After this type, 
 
  go to frame "option a" 
 
   (include the inverted commas when describing markers in a script) 
 
19 Now add a script to button b so that when it is selected it takes the user to option b.  
 ie:- on mouseUp 
 
  go to frame "option b" 
 
20 Now add your third graphic into the movie. This graphic will act as a button to return 

the user from both option a and option b back to frame 1 of the movie. Therefore it 
should be added into the option a section (frames 40-42) and the option b section 
(frames 60-62.)  

 
21 Now add a script to this graphic in the cast window to take you back to frame 1. In 
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it's script window, type  
  go to frame "begin movie" 
 
22 From the Control menu, select 'Recompile all scripts.' Small icons should appear in 

the bottom left corner of your cast member icons indicating they now have scripts 
attached! It is good practise to recompile your scripts on a regular basis while 
scripting. Save your movie, rewind and play. 
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Part 4- Adding Sound to the movie 
 
Sound as a "Soundtrack" 
 
To lay sound across a section of Director's score , in order to create a "synch  

soundtrack" to your movie, do the following. 
 
1 Import AIFF format sound file(s) into Director by opening the cast window 

and selecting Import. (Make sure you are selecting sound files rather than 
graphics files.) 

 
2 Open up the Director score. To lay a sound over the first sequence in the 

movie ( ie the animated sequence), drag the desired sound cast member into 
either Channel 1 or Channel 2 of the sound channels in the score.  

 (Sounds are unable to be accidentally dragged into the "vision" channels of 
the score). Start the sound at frame 2 since there can sometimes be problems 
laying sound from the very beginning of a sequence. 

 
3 Extend the frames in the sound channel until all of the vision 
 frames of your initial animated sequence have sound laid over them.  
 Play your movie. (Your sound may be too long or too short for your 
 animated sequence- what can you do to fix this???.) 
 
4 Now lay a different sound into a sound channel to cover the "option a" 
section of your movie. Do the same for "option b". 
 
5.  Play back your movie and check how the sounds are playing back. 
 
 
Puppet Sounds 
 
 Director can also allow you to trigger sounds as a result of user actions 
such as mouseUp commands. Such sounds, enabled by lingo scripts, are called 
Puppet Sounds. Puppet Sounds play from Channel 1 of Director (so if you 
already have a sound playing in Channel 1, it will stop that sound.) 
 
Try the following exercise. 
 
 1 Import a new AIFF sound file into Director (by opening the cast 
window and selecting Import.) Make sure that the sound has a name. 
 
 2.  Go to the cast window and select one of the graphics that are acting 
as a button in your movie ( eg the graphic acting as the return button).  
  
 3.  Open up the script window of this cast member and type in the 
foloowing script (making sure you insert the correct name of your own sound 
file into the script) 
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  on mouseUp 
   puppetSound "insert name of your sound file here" 
   you will also have a line of script here 
  end 
 
 4.  Close up the script window and play your movie. Your puppet 
sound should now be triggered when you click on the appropriate button. 
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